Cumulative Area and AutoCAD Hatches

Cumulative Area and AutoCAD Hatches

I was asked this question recently:

I noticed the “cumulative area” when attempting to add up SF numbers from multiple polygons. Please see the two images below. Why can I select 4/5 polygons and have it add them in the cumulative area space (Shown in Image 1) but when I select the 5th area the cumulative area disappears (Shown in Image 2)? Do you know why this occurs?

Screen Capture 1
Image 1
Screen Capture
Screen Capture 2

I suspected that there was a boundary issue, that prevented the hatch from calculating the area.  This can occur when a polyline boundary overlaps itself before its closed.  Since a hatch can generate a new boundary, I felt that was the easiest way to resolve the problem.  Here is my response:

The problem exists with the last hatch area. If you select it by itself, it displays no Area. I suspect that the boundary is probably overlapping itself. It’s not related to the number of hatches chosen, it’s actually that hatch by itself. To fix it, I did this:

1.) Unfreeze the layer containing the hatch, and make it current.
2.) Isolate that layer so only the hatch objects are visible. You can use layiso to isolate the layer containing the hatch.

Screen Cap 3
Image 3

3.) Now that the hatch is visible and isolated, select the problem hatch, right click and choose generate boundary.

Screen Capture 4
Image 4

4.) Once the new boundary is created, you can delete the original hatch.
5.) Use boundary hatch to place a new hatch into the generated boundary, to match existing hatches already created, you can use match properties.

Screen Capture 5
Image 5

 

Viola problem solved.