V-Ray for Revit not finding a license?

V-Ray for Revit not finding a license?

After installing V-Ray for Revit public beta the other day, I rebooted my workstation and found that everytime I launched Revit, there was a delay and V-Ray would error out with a message indicating that no license was available.

Revit throws error when VRay seeks license server from existing install
Revit throws error when VRay seeks license server from existing install

Since I knew that I had successfully installed and had ample licenses available, the problem must be in a setting somewhere.  I checked the localhost:30304 server and found plenty of unused licenses on the online tab.  Since I have an install for Sketchup and 3DSMax, I thought that the new beta may be using an existing mechanism to find  the server.  I suspected that the 3DSMax license tool was telling Revit to look in the wrong place.  Once I reconfigured the original install to use localhost as primary and moved the network ip location to the “Alternate Server 1” slot, Revit was able to pull licenses when launched.

Steps to fix this issue:

Find the chaos group folder under your start menu.

Within the 3DSMax tools find the license administration folder

Right click and choose “Change V-Ray…”

3dsmax license controller

 

When the V-Ray License Server information dialog box displays, make sure that “localhost” is assigned to the primary license server with 30304 as the connection port.  If you were grabbing a license from a dongle attached to another machine(s), just add them in Alternate license server 1 and/or 2.

restoring localhost for online licensing

This worked for me… your mileage may vary.